7. Więcej informacji

Doszedłes aż dotąd i jeszcze ci mało! Gdzie jeszcze możesz iść, by się nauczyć więcej o wszystkich tych rzeczach?

7.1. man Pages

Sprawdź poniższe strony mana, dla początkujących:

7.2. Książki

Jeśli jesteś zwolennikiem starodawnych, "trzymanych w rękach", miękich, papierowych książek, sprawdź poniższe wspaniałe przewodniki. Zauważ wybitne logo Amazon.com. Cały ten bezwstydny komercjalizm jest dlatego, że ja na tym zyskuje (upusty w Amazon.com) za sprzedawanie tych książek za pośrednictwem tego przewodnika. Więc jeśli zamierzasz zamówić jedną z nich, dlaczego nie wyrazisz specjalnego podziękowania, poprzez użycie poniższych linków?

Dodatkoweo, więcej książek dla mnie prowadzi do większej ilości przewodników dla ciebie. ;-)

Unix Network Programming, volumes 1-2 by W. Richard Stevens. Published by Prentice Hall. ISBNs for volumes 1-2: 013490012X, 0130810819.

Internetworking with TCP/IP, volumes I-III by Douglas E. Comer and David L. Stevens. Published by Prentice Hall. ISBNs for volumes I, II, and III: 0130183806, 0139738436, 0138487146.

TCP/IP Illustrated, volumes 1-3 by W. Richard Stevens and Gary R. Wright. Published by Addison Wesley. ISBNs for volumes 1, 2, and 3: 0201633469, 020163354X, 0201634953.

TCP/IP Network Administration by Craig Hunt. Published by O'Reilly & Associates, Inc. ISBN 1565923227.

Advanced Programming in the UNIX Environment by W. Richard Stevens. Published by Addison Wesley. ISBN 0201563177.

Using C on the UNIX System by David A. Curry. Published by O'Reilly & Associates, Inc. ISBN 0937175234. Out of print.

7.3. W sieci

W sieci:

BSD Sockets: A Quick And Dirty Primer (posiada również informacje na temat programowania systemowego w Uniksach!)

The Unix Socket FAQ

Client-Server Computing

Intro to TCP/IP (gopher)

Internet Protocol Frequently Asked Questions

The Winsock FAQ

7.4. Dokumenty RFC

RFCs--prawdziwy brud:

RFC-768--The User Datagram Protocol (UDP)

RFC-791--The Internet Protocol (IP)

RFC-793--The Transmission Control Protocol (TCP)

RFC-854--The Telnet Protocol

RFC-951--The Bootstrap Protocol (BOOTP)

RFC-1350--The Trivial File Transfer Protocol (TFTP)